HomeНаука и техникаRelated VideosMore From: Chris Walker

Windows 7: reset tcp/ip and winsock

411 ratings | 170636 views
TCP/IP is a set of protocols used to access the Internet and other networks. It is possible for the Windows software that deals with TCP/IP to become corrupt. This video uses Windows 7, but these commands work on Microsoft Windows Vista, XP, 2000, Windows Server 2003 and 2008. This video resets both the TCP/IP stack and winsock. The commands I use are: netsh int ip reset netsh winsock show catalog netsh winsock reset Providing training Videos since last Tuesday http://www.technoblogical.com Thanks for Watching!
Html code for embedding videos on your blog
Text Comments (118)
doğru adres (2 months ago)
You fucking my computer missing operating system
Roger Rodis (3 months ago)
Big help! Thank you!
Help, what do I do?At the end it appeared notepad window with message of start with failure error code 10107?
Fauzan Adrian (5 months ago)
you the man bro,ive know nothing about pc,had search all over google and after following this video my problem solved
jermaine kardel (5 months ago)
THANKS MAN!
Jongo Feta (6 months ago)
Access is denied, ples help
AngelRasko (6 months ago)
До чего же вы, америкосы, тупые. Проблемы, связанные с winsock почаще итого связаны с жучками АНБ, которые попадают в компы НЕамериканцев с программным обеспечением американских компаний (Apple, Adobe, etc.) выпилить их с помощью стандартных средств, всё равно что отремонтировать движок автомобиля подменой масла. А во всем вините "российских взломщиков". Стадо непуганых кретинов. Овцы.
T H I C C (7 months ago)
\
Martin Lamas (1 year ago)
Chris, I went to cmd as an admin and typed "netsh int ip set dns". That worked ok, but when i typed "netsh winsock reset", i got the dreadful "Access is denied" error. Any ideas/solutions ? Thanks.
Mothepro The blogger (1 year ago)
Brilliant video thanks for your help!! All sorted
Tariq 24 (1 year ago)
does this change the ip address?
Raziel (1 year ago)
OMG you are the best bro!!! i love you!!! :D
Jeanjacques Cohen (1 year ago)
thank you so very match,you are the best..!
M3ch/Alone_wolf (1 year ago)
i can connect to the internet but if i go on my gaming clan website it says tcp connection rejection
RAHUL GUPTA (1 year ago)
thank u so much
Cherian Rocky (1 year ago)
Very useful.. Thank you
`COLT. (1 year ago)
omfg thx so muuuch!! +1sub :)
Asmae Fares (1 year ago)
omg thank you so much i was really starting to freak out when my network wouldn't work and you literally saved me thank you thank you thank you <3 i really appreciate it you have no idea
Cartoon World (1 year ago)
thank you man.....=)) you 've save my life.
Ardana Pranasta (1 year ago)
hey iam done but failed D: "the requested operation requires elevation <Run as Administrator>" pls help me
Kanan Mammadov (1 year ago)
Ardana Pranasta click the rigt click to the cmd to run as an administrator
Stepotato (1 year ago)
Omg so thank's a lot!!!;) Like
Codgamer Stark (1 year ago)
I tried, and it said access denied
Riojr100 (7 months ago)
Try to run cmd.exe with Administrator.
Space Dandy (1 year ago)
Can you use this method to undo changes made from things like TcpNoDelay? Like will it reset those values to default? I want to undo some changes I made to the TCP/IP folder when I was gaming on MMO's and see what the comparison is, but I don't want to go messing with my computers registry and possibly ruin my computer.
TheAidiwashere (1 year ago)
Thank god, thank you!
Nate (2 years ago)
mine don't work it tells me helper DLL not found
yousify (2 years ago)
Thank you so much, I've tried a lot, I reached the point that I will reinstall the windows, but you helped me. it really means a lot. I hope God will help you at the time you need it as you help me. Thank you again.
TheVagrant (2 years ago)
OMG thanks!!!
Owen Mcallister (2 years ago)
it worked my life is improved 100% thanks man,
karan kawad (2 years ago)
thanks bro my tally was saved thank you for this video
kkkkjjjjjeeee (2 years ago)
anyway to reset tcp without reboot? unix can do that, dmn, i hate windows.
Dinastey (2 years ago)
Thanks for nothing!
Zaster Tune (2 years ago)
still doesnt work ....
Kwazy (2 years ago)
I got a usb wifi adaptor suddenly it said the error windows socket iniliazer thingie and there was no connection and when i went to the panel it showed that it was not working im startung my pc now hopes it works.... It still doesnt connect to wifi dont know why i think i might have to reinstall the program wish me luck
Jonas Marken (2 years ago)
I tried it but it didn't work, it still says limited access and the dependency service or group failed to start in the network and sharing centre, it started as I used ccleaner 2 days ago as it somehow removed the wifi conection. I will let you know when I get it fixed. Luckily I have another pc to use.
Fiqki Azizah (2 years ago)
thank you!!!!!!!! finally my browser can connect to the Internet again.... thank you so much!!
Richard H Badgley (2 years ago)
Didn't work for me. In system summary it says ws2ifsl (winsock IFS driver) is disabled, about the same time a yellow dot (or sun) showed up covering the signal strength graph in the taskbar, even though I have internet access. Are these related? I followed your instruction in cmd everything reacted the same as what I saw in your video except repairing the winsock. HELLLLLLLLP!
THANK YOU SO MUCH I THOUGHT MY MOTHER WILL BE MAD WHEN SHE SAW windows socket initialize failed BUT ITS FIXED BEFORE SHE SEE IT THANKS MAN
BOOF MOOSE (2 years ago)
I did netsh winsock reset and it fixed the problem with my game but then my whole pc couldn't access the internet and i have to do system restore to the point before i did the command prompt. Do you know why this is?
Panos None (2 years ago)
Thnx a ton mate, had a problem with "error initializing network layer - winsock: socket failed (87)". Problem solved thnx to you (i wasnt able to find a solution anywhere else).
Chris (3 years ago)
I Love u man! Thanks, that helped very well!😍 Greetings from Germany👋🏻
K.NG_ 'K4 (3 years ago)
yes yes yes yes it works finaly i kiss you smaaaackkkkkkkk
Anthony Padilla (3 years ago)
I tried everything, but none of the methods wouldn't work. I almost gave up until I stumbled upon this beautiful tutorial... I swear I jumped and cheered then flipped off my computer in triumph. THANK YOU!
Girl from_Dragonstone (3 years ago)
When I do the netsh int ip reset c:\reset.txt & press enter I get "There's no user specified setting to be reset" I run it as the admin...Please help if you can. Thanks in advance!
vide0gameCaster (2 years ago)
+Girl from_Dragonstone If there a multiple users saved in the PC, I suggest that delete every one of them and just keep the Admin User up. Try that again, it might not confuse the CDM prompt.
Howie (3 years ago)
Adam Goodrich (3 years ago)
THANK YOU
Noor Uddin (3 years ago)
It is really painful when network is not working......Thanks for the solution.... its work for me excellent.....
Vicki Bradley (3 years ago)
I was finally able to get some results, which hadn't happened before....LOL. However, it tells me at the end that "The following command was not found: winsock.reset"  What should I do now?? Thank you soooooo much!!!!!
Fisk Balle (3 years ago)
Thank you:DDD, i uninstalled a program that i did not need and my internet stopped working on my pc i searched for several different downloads, but how can i download with no internet on my pc, So Thanks: DDD
Thank you :D I LOVE U! xD
Chad Lamon (3 years ago)
still says access is denied
Ali Nur (3 years ago)
thanks, work for me too!! win xp SP3 !
Trask24 (3 years ago)
fixed a few computers with this....Thank you
Fresia Peñafiel (3 years ago)
GRACIAS CABALLERO DIOS LE BENDIGA
pete1201 (3 years ago)
Thank you so much for getting my laptop working correctly.....huge thumbs up!!!
cskillers1 (3 years ago)
heey thanks a ton pal o/ winsock helped me with my wtfast problem ^^
cskillers1 (3 years ago)
oh my gosh xD, thanks again Chris! , your video helped me once again ^^;
Weny Alves (3 years ago)
thanks, work for me!!
Ahmed Tamer (4 years ago)
i visit this video alot thank you really
angel alejandro (4 years ago)
Can I use it in win 8?
angel alejandro (4 years ago)
I can use it in win 8 
Brandon (4 years ago)
Worked, thanks man. I didn't even need to restart my PC
Napo (4 years ago)
Thank you sooooo much c: thank uuu <3333 works again thanks
Napo (4 years ago)
Idk what happent to my pc its just from one day to another winsock is broken :c
Napo (4 years ago)
Great c:
michalis stargun (4 years ago)
thanks i did it :)
Napo (4 years ago)
yes very simple just open cmd with adminstrator then type the things in
michalis stargun (4 years ago)
me too :/ you found how to fix it?
David R. Flores (4 years ago)
Nice man, thanks for sharing!
mrsquishyboots (4 years ago)
I did all of this and none of my browsers are working. My phone and ps3 connect just fine to the wifi but my windows machine isn't connecting at all. Firefox just blinks.
mrsquishyboots (4 years ago)
I did all of this and none of my browsers are working. My phone and ps3 connect just fine to the wifi but my windows machine isn't connecting at all. Firefox just blinks.
Randy Schirmer (4 years ago)
My problem is that any attempt to reset anything (for example netsh winsock reset) results in: Initialization Function InitHelperDll in NSHHTTP.DLL failed to start with error code 1103 Successfully reset the Winsock Catalog Restarting the computer doesn't fix the error. I have seen others with the same problem even after going through all of the steps that Microsoft personnel  had them follow. And at that point the MS person simply disappears with no more posts. I am assuming that the initialization function is part of the resetting process and that Windows isn't smart enough to report that the rest process while completing, didn't really do a proper reset. I get the same error resetting TCPIP. Another thing they do is tell people to use the Event Viewer to see why the service failed while the problem is that the EventViewer doesn't work. I don't know if you have any idea as to what to do. Any use of netsh generates the initialization error. When I just type netsh and I get the error, it goes into the netsh command prompt. I do the rests from there. They say they were successful but the issue persist. What part does that function play in running netsh? I can view the catalog but how do I know what I see is correct? If you cna help great! If not I understand. Microsoft's support team members don't even address it. As I said they disappear once it gets to this point.  It's a good video.  Thanks. Randy
Thresh Main12 (4 years ago)
Hey do I have to use those 3 command to reset my computer ?
Shira Shapira (4 years ago)
Solved - Saved the day - Works like a charm!!
sam24u a1 (4 years ago)
save the day! Many thanks, do you know of a regfix or batch or ms fixit that would do it all in one shot?
brutus178 (4 years ago)
MAR 29/14 i was getting blue screen error every time I turned on my computer I have windows 7 ultimate, I am a computer dummy. I had to keep starting my computer in safe mode and restore to previous date to get on line.  This fixed my computer and now when I shut down it loads properly on start up, thank you so very, very much for posting this, the problem I did have that I had to get a guy from work to tell me what the error code on the blue screen meant so I could find your fix solution. thank you
Dillon Jones (4 years ago)
Mother of god. Thank you sooooo much...
sauce (2 years ago)
+Dillon Jones lmao mother of god
Dillon Jones (4 years ago)
Any time friend.
Chris Walker (4 years ago)
Thanks for the absurdly appreciative comment. It got a chuckle.
Antimatter31 (4 years ago)
If I were to plug in a wifi dongle, would that be a permanent fix. Cos before I had my computer, I cant remember having to do this. Is the network adapter corrupt?
Mundy Willaims (4 years ago)
you're the best my friend.  I've been trying to connect for the last week are so with no success.  Out of all the google searches, the info that you provided was the only one that really did the job.  Thank you
R1rippin (4 years ago)
Your video was awesome!  Everytime I opened a browser my pc would get the bsod, everything else worked fine.  The bsod would show the problem as being the tcpip and found your video on my phone, and my pc works great now! I tried for 4 days and countless hours to try and fix it with hotfixes from MS and many other so called fix it's, nothing worked but this did! Thanks for posting this video!
Sidhartha Raj (4 years ago)
How do i get the administrator? It keeps saying operation requires elevation (run as administrator) thanks
Lisa Snipes (4 years ago)
what is the output file you used?
Lisa Snipes (4 years ago)
I am computer illiterite and I can't see what you are typing in can you plz show that. Thanks
F22Acura (5 years ago)
Will this get rid of both my pv4 ips when i type in ipconfig because i try cybergate and i use no-ip but it wont detect the ports ive fowarded on my router hopes this fixes it if so ill post a tut on hackforums
777jonah888 (5 years ago)
hi,Winsock entries tells Windows 7 how to access your network services. Additionally, your TCP/IP protocol can be corrupted. The TCP/IP protocol is a stack of 4 layers that includes several transport layers, but when this stack is corrupt you will constantly have connectivity issues. netsh winsock reset catalog (reset winsock entries) netsh int ip reset reset.log hit (reset TCP/IP stack)
777jonah888 (5 years ago)
do you have wireless icon on task bar( bottom right corner of desktop? click it and wireless ap will show - does it work? did wireless ever work on lt?
777jonah888 (5 years ago)
VISTA AND 7 ARE ALMOST IDENTICAL OSs
nero kaimera (5 years ago)
thnx thnx thnx thnx thnx a lot frome me im نعمان frome morocco im arabian love this it worked 2013 for me nice!!!
Ethernal Envyy (5 years ago)
sposibo 4uvak
siggie12 (5 years ago)
Just like magic. My sincere and humble thanks.
Lost in Hilbert Space (5 years ago)
I LOVE YOU! Making my first born after you. thank you so so much!!
socorro ouano (5 years ago)
you sir have been very blessed by God, Thankyou soooo much God Bless :D
CrimelabS (5 years ago)
That last line you said that's the reason why we need to reset TCP/IP protocols to default? Do some apps (skype, yahoomessenger, utorrent) make changes on these 'rules'? I'm having a hardtime explaining details with my clients except it resets settings to default configuration.
bmnbl (5 years ago)
My win7 laptop doesnt detect my wireless network or any other, but works fine via LAN connection. Wireless is working and has the blue led working (Fn + F2). Would this be helpful?
HyabusaXZX (5 years ago)
Plz help does this work for my ps3 servers not connecting
Maestro (5 years ago)
please send me the commands . because I have a problem with a service point
Chris Walker (5 years ago)
Both.
i Chief (5 years ago)
does this work for windows 7? or just vista?
장성권 (5 years ago)
thx
gottagetaway (6 years ago)
You are an utter legend. Quick, to the point and did the job. The internet needs more people like you. thank you :)
Chris Walker (6 years ago)
It's a stack of protocols (rules) that provide a consistent experience along a network. In the early days, Apple used AppleTalk. Windows used NetBIOS to communicate over the network. Novell used NetWare. Eventually, everyone got tired of proprietary protocols, and we all settled on TCP/IP protocols. Then it became much easier for my Linux communicate to your Windows and some one else's Mac. Thus the internet was born. Though many companies still try to push their own proprietary stuff.
Patrick Villanueva (6 years ago)
I'm dumb but what does the TCP/IP do actually help
SmallSkinnyGuy (6 years ago)
Thank you very Much! After I did a reset using the netsh winsock reset command that I read from an article first then I found your video on YouTube to further help me with this issue in the future. Are there any chances of this happening again to the same computer for any reason?
Emir Fahmi (6 years ago)
if I accidentally extinguish afd.sys how should I make
Evilbones76 (6 years ago)
Thanks.

Would you like to comment?

Join YouTube for a free account, or sign in if you are already a member.